Есть вопрос?
Зайди на форум

Поиск на сайте: Advanced

Denix - новый дистрибутив Linux. Русификация Ubuntu и установка кодеков

dkws.org.ua
Форум сайта dkws.org.ua
 
Главная    ТемыТемы    АльбомАльбом    РегистрацияРегистрация 
 ПрофильПрофиль   Войти и проверить личные сообщенияВойти и проверить личные сообщения   ВходВход 

Chicony CNF7129 WebCam

 
Начать новую тему Ответить на тему    Список форумов dkws.org.ua -> Железо
 
Автор Сообщение
mekkanizer

Участник тусовки


Зарегистрирован: 04.09.2008
Сообщения: 230

СообщениеДобавлено: Сб Окт 12, 2013 3:20 pm    Заголовок сообщения: Chicony CNF7129 WebCam
Ответить с цитатой

Доброго времени суток.
Есть ASUS eee-PC 1000H. В нем установлена означенная веб-камера и lubuntu 13.04. В скайпе и guvcview изображение отсутствует.
Проблема в том, что как не вбивай эту проблему в гугл, найдутся только темы 2009/10 годов где советуют одно и то же - запускать скайп следующим образом
Код:
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype

Это ничего не меняет. При запуске скайпа терминал говорит
Код:
libv4l2: error dequeuing buf: Устройство или ресурс занято

Я эту ошибку и в таком виде и в английском варианте (resource temporarily unavailable) изгуглил и все равно ничего не нашел.
Guvcview говорит то же самое (захват изображения невозможен - ресурс временно недоступен)
Помогите, пожалуйста. Может libv4l можно/нужно обновить? Дрова какие-то откуда-то скачать? С какими то другими ключами скайп запускать?
_________________
Вернуться к началу
Посмотреть профиль Отправить личное сообщение Отправить e-mail
mekkanizer

Участник тусовки


Зарегистрирован: 04.09.2008
Сообщения: 230

СообщениеДобавлено: Сб Окт 19, 2013 4:02 am    Заголовок сообщения:
Ответить с цитатой

жаль
_________________
Вернуться к началу
Посмотреть профиль Отправить личное сообщение Отправить e-mail
Konstantin

Завсегдатай


Зарегистрирован: 01.05.2006
Сообщения: 615

СообщениеДобавлено: Сб Окт 19, 2013 9:30 am    Заголовок сообщения:
Ответить с цитатой

Не расстраивайся
SOLVED
http://ubuntuforums.org/showthread.php?t=2100973&page=2&s=4521b8f1ba8dda12fd770d4fe785427b
надо было сделать
sudo apt-get install libv4l-0
Вернуться к началу
Посмотреть профиль Отправить личное сообщение
den

Старожил


Зарегистрирован: 31.01.2006
Сообщения: 13714
Откуда: Кировоград, Украина

СообщениеДобавлено: Сб Окт 19, 2013 3:01 pm    Заголовок сообщения:
Ответить с цитатой

Как оказалось, ларчик просто открывался )
Вернуться к началу
Посмотреть профиль Отправить личное сообщение dhsilabs@jabber.ru
mekkanizer

Участник тусовки


Зарегистрирован: 04.09.2008
Сообщения: 230

СообщениеДобавлено: Вс Окт 27, 2013 11:26 am    Заголовок сообщения:
Ответить с цитатой

Konstantin, спасибо за помощь, но я тоже не дурак погуглить
Код:
Уже установлена самая новая версия libv4l-0.
libv4l-0 установлен вручную.

И потом, неужели не ясно, что libv4l уже установлен по тому, что я пытался делать вот так
Код:
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype
и даже написал, что это ничего не меняет.
Так что вопрос остается открытым
_________________
Вернуться к началу
Посмотреть профиль Отправить личное сообщение Отправить e-mail
Konstantin

Завсегдатай


Зарегистрирован: 01.05.2006
Сообщения: 615

СообщениеДобавлено: Вс Окт 27, 2013 5:56 pm    Заголовок сообщения:
Ответить с цитатой

В приведенной мною ссылке говорится, что надо делать так
Exec=bash -c 'LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype'

вместо просто
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype
ТЫ ТАК ДЕЛАЛ?
А теперь сделай все под рутом


Последний раз редактировалось: Konstantin (Вс Окт 27, 2013 6:10 pm), всего редактировалось 1 раз
Вернуться к началу
Посмотреть профиль Отправить личное сообщение
Konstantin

Завсегдатай


Зарегистрирован: 01.05.2006
Сообщения: 615

СообщениеДобавлено: Вс Окт 27, 2013 6:09 pm    Заголовок сообщения:
Ответить с цитатой

mekkanizer писал(а):
Konstantin, спасибо за помощь, но я тоже не дурак погуглить
Код:
Уже установлена самая новая версия libv4l-0.
libv4l-0 установлен вручную.

И потом, неужели не ясно, что libv4l уже установлен по тому, что я пытался делать вот так
Код:
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so skype
и даже написал, что это ничего не меняет.
Так что вопрос остается открытым


Не надо возмущаться. Если ты делал
LD_PRELOAD=/usr/lib/i386-linux-gnu/libv4l/v4l1compat.so
это не означает, что ты установил сам пакет
Вернуться к началу
Посмотреть профиль Отправить личное сообщение
mekkanizer

Участник тусовки


Зарегистрирован: 04.09.2008
Сообщения: 230

СообщениеДобавлено: Вс Ноя 03, 2013 2:36 am    Заголовок сообщения:
Ответить с цитатой

Konstantin,
поправьте меня, если я ошибаюсь, но если бы я этот пакет не ставил терминал бы ругнулся.
_________________
Вернуться к началу
Посмотреть профиль Отправить личное сообщение Отправить e-mail
Показать сообщения:   
Начать новую тему Ответить на тему    Список форумов dkws.org.ua -> Железо Часовой пояс: GMT
Страница 1 из 1
 Главная страница сайта
 
Перейти:  
Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете голосовать в опросах
© Колисниченко Денис